At times, you or your clients may notice multiple, duplicated, or unexpected items appearing on the training calendar. While this can be confusing, the issue usually has a simple explanation. Below are the most common causes behind this occurrence, with potential ways to resolve and prevent this in the future.
Common Causes
1. Copying or Importing Programs/Phases
When a program or a training phase is copied, imported, or duplicated (from another client, a Master Program, or within the same program), all saved calendar items are also transferred.
This includes:
- Workouts
- Cardio activities
- Auto-messages
- Body stats
- Habits
2. Client Activity on the App
Clients may unintentionally create duplicates when they move or reschedule events in the app. To limit a client's ability to reschedule or move events, review your Client Permission Settings.
3. Wearable sync Issues
Wearables such as Fitbit, Apple Healthkit and Garmin connected to the ABC Trainerize app may be syncing over multiple cardio events if they are connected to a third-pary health syncing app. Please ensure that clients have not connected their wearables through a third-party sync, and ensure only integrations available to connect through ABC Trainerize are set up.
How to Resolve the Issue
1. Bulk Delete Calendar Items
You can bulk delete calendar items by selecting the Trash Can icon in the top right of your client's calendar. Ensure to select the proper date range and choose 'Scheduled/Missed' items.
Note: this action deletes incomplete/missed workouts for the selected program and cannot be undone. For full step-by-step details on bulk deleting calendar items, visit: How Do I Mass Delete Calendar Items (Workouts, Cardio, Auto Messages)?
2. Troubleshoot Browser Issues
If the duplication appears only on the web:
- Clear the browser cache to reset your browser.
- Review browser extensions- disable or toggle them to test if one is interfering.
Preventive Measures
1. Educate Clients: Share best practices for using the app and syncing third-party devices.
2. Check Calendars Regularly: Encourage trainers and clients to review calendars before copying and/or importing programs.
3. Import Workouts (Not Entire Phases): If you wish to reuse the same workouts for a client's next training phase, or for another client, follow these steps instead of duplicating:
- Create a new blank phase.
- Import workouts from the client's previous phase (By selecting "Import Workout from Client Program")
- Adjust as needed before scheduling
Duplicate or unexpected calendar items are usually caused by program duplication, client rescheduling, or wearable sync issues. By following the troubleshooting steps above and adopting preventive measures, you can maintain a clean and accurate calendar for a smoother training experience.